远景视讯

 
 


锐捷核心交换机RG18012-VSU基本配置
(2019-6-4)



1、VSU基本配置

 

1、对主备核心交换机进行初始配置

 

核心交换机1:

 

Switch1# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch1(config)# switch virtual domain 1

Switch1(config-vs-domain)# switch 1

Switch1(config-vs-domain)# switch 1 priority 200    ------>默认优先级为100配置为较高的优先级VSU建立成功后将会成为管理主机。

Switch1(config-vs-domain)# exit

Switch1(config)# vsl-port 1         ------>VSL链路至少需要2一条链路可靠性较低当出现链路震荡时VSU会非常不稳定。

Switch1(config-vsl-ap-1)# port-member interface TenGigabitEthernet 2/1            ------>配置VSL链路

Switch1(config-vsl-ap-1)# port-member interface TenGigabitEthernet 2/2

Switch1(config-vsl-ap-1)# exit

 

 

核心交换机2

 

Switch2# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Switch2(config)# switch virtual domain 1  ------>domaind id 必须和第一台一致

Switch2(config-vs-domain)# switch 2     ------>第二台设备必须更改ID2

Switch2(config-vs-domain)# switch 2 priority 150

Switch2(config-vs-domain)# exit

Switch2(config)# vsl-port 1 ------>VSL链路至少需要2一条链路可靠性较低当出现链路震荡时VSU会非常不稳定。

Switch2(config-vsl-ap-1)# port-member interface TenGigabitEthernet 2/1   ------>配置VSL链路

Switch2(config-vsl-ap-1)# port-member interface TenGigabitEthernet 2/2

Switch2(config-vsl-ap-1)# exit

 

2、连接好VSL链路,并确定接口已经UP

 

 

3、保存两台设备的配置,并一起切换为VSU模式

 

核心交换机1

Switch1# wr

Switch1# switch convert mode virtual         ------>转换为VSU模式

Convert mode will backup and delete config file, and reload the switch. Are you sure to continue[yes/no]yes

Do you want to recover config file from backup file in standalone mode (press 'ctrl + c' to cancel) [yes/no]no

no表示清空重配, 

 

核心交换机2

Switch2# wr

Switch2# switch convert mode virtual  ------>转换为VSU模式

Are you sure to convert switch to virtual mode[yes/no]yes

Do you want to recover config file from backup file in virtual mode (press 'ctrl + c' to cancel) [yes/no]no

 

选择转换模式后,设备会重启启动,并组建VSU。

 

 

4、确认VSU建立成功

 

1.VSU的管理需要在其中的主机上进行

2. VSU主机的引擎Primary灯绿色常亮,VSU从机的Primary灯灭,可以用来判断主从机关系(设备优先级提前有指定,高优先级的设备会成为主机)

3. VSU组建后从机Console口默认不能进行管理,可执行EscEscEscEscC(即4次Esc键加C键)打开输出开关,建议使用session device 2 slot (m1,m2 ,线卡槽位)登录其它设备查看信息。

 

Ruijie# show switch virtual role  检查主备是否符合预期

Switch_id     Domain_id     Priority     Position     Status     Role               Description                     

----------------------------------------------------------------------------------------------------------------

1(1)          100(100)      200(200)     LOCAL        OK         ACTIVE           switch-1    ------>ACTIVE表示主机箱                         

2(2)          100(100)      150(150)     REMOTE     OK         STANDBY       switch-2     ------>STANDBY表示从机箱                

 

Ruijie# show ver slots  检查是否已经识别到了主从机的所有线卡说明以下结果仅为示例

Dev Slot Port Configured Module            Online Module                Software Status

  --- ---- ---- ---------------------------- ---------------------------- ---------------

  1   1    0    none                         none                         none          

  1   2    0    none                         none                         none          

  1   3    8    M18000-08XS-ED               M18000-08XS-ED               ok             

  1   4    0    none                         none                         none          

  1   5    48   M18000-24GT20SFP4XS-ED       M18000-24GT20SFP4XS-ED       ok            

  1   6    0    none                         none                         none          

  1   7    7    RG-WALL 1600-B-ED            RG-WALL 1600-B-ED            ok            

  1   8    0    none                         none                         none          

  1   FE1  0    N/A                          M18010-FE-D I                ok            

  1   FE2  0    N/A                          M18010-FE-D I                ok            

  1   FE3  0    N/A                          none                         none          

  1   FE4  0    N/A                          none                         none          

  1   M1   0    N/A                          M18010-CMII                  master        

  1   M2   0    N/A                          none                         none          

  2   1    0    none                         none                         none          

  2   2    0    none                         none                         none          

  2   3    8    M18000-08XS-ED               M18000-08XS-ED               ok            

  2   4    0    none                         none                         none          

  2   5    48   M18000-24GT20SFP4XS-ED       M18000-24GT20SFP4XS-ED       ok            

  2   6    0    none                         none                         none          

  2   7    7    RG-WALL 1600-B-ED            RG-WALL 1600-B-ED            ok            

  2   8    0    none                         none                         none          

  2   FE1  0    N/A                          none                         none          

  2   FE2  0    N/A                          M18010-FE-D I                ok            

  2   FE3  0    N/A                          none                         none          

  2   FE4  0    N/A                          none                         none          

  2   M1   0    N/A                          none                         none          

  2   M2   0    N/A                          M18010-CMII                  backup 

 

 

 

2、VSU优化配置

 

1、配置双主机检测及例外口

 

为什么要配置双主机检测?

1.当VSL的所有物理链路都异常断开时,从机箱认为主机箱丢失会切换成主机箱,网络中将出现两台主机箱,两台机箱的配置完全相同,在三层,两台机箱的任何一个虚接口(VLAN接口和环回接口等等)的配置相同,网络中将会出现IP地址冲突,导致网络不可用。

     

2.配置双主机检测机制后,BFD专用链路会根据双主机报文的收发检测出存在双主机箱,系统将根据双主机检测规则选择一台机箱(低优先级机箱)进入恢复(recovery)模式,除VSL端口、MGMT口和管理员指定的例外端口(保留作为设备其他端口shutdown时可以Telnet)以外,其它端口都被强制关闭。

 

所以双主机检测可以阻止以上异常故障出现时,保障网络依然可用(前提是其他设备连接到双核心都具备冗余链路条件

VSU配置

Ruijie(config)# interface gi2/4/2

Ruijie(config-if- GigabitEthernet 2/4/2)# no switchport ------>配置检测接口 2 为路由口

Ruijie(config-if)# exit

Ruijie(config)# interface gi1/4/2

Ruijie(config-if- GigabitEthernet 1/4/2)# no switchport  ------>配置检测接口 1 为路由口

Ruijie (config-if)# exit

 

 

Ruijie (config)# switch virtual domain 1 ------>进入VSU参数配置

Ruijie(config-vs-domain)# dual-active detection bfd ------>打开 BFD 开关,缺省关闭

Ruijie(config-vs-domain)# dual-active bfd  interface gi1/4/2     ------>配置一对BFD 检测接口

Ruijie(config-vs-domain)# dual-active bfd  interface gi2/4/2

Ruijie(config-vs-domain)# dual-active exclude interface  ten1/1/2   ------>指定例外口上联路由口保留出现双主机时可以telnet

Ruijie(config-vs-domain)# dual-active exclude interface  ten2/1/2    ------>指定例外口

 

2、配置OSPF GR

 

为什么要配置OSPF GR?

1. VSU/双引擎主备切换时,OSPF等动态路由协议邻居会重新建立,导致网络中断或数据流路径切换。

2. 配置GR(完美重启)功能后,GR能够保持邻居间的OSPF邻居关系不中断,管理面重启时数据面依然正常按照原有路径转发。

注意:11x交换机缺省开启GR(完美重启)功能。

 

OSPF GR功能需要邻居设备支持并开启GR Helper(我司设备如支持GR Helper 则默认开启,无需配置),邻居不具备GR Helper功能时,VSU主从机异常切换时

OSPF邻居关系依然会中断,造成网络短暂中断。

 

VSU配置

Ruijie(config)#router ospf 1

Ruijie(config-router)#graceful-restart   ------>开启GR功能

 

邻居设备需要配置GR-helper功能我司设备如支持GR-helper则默认打开无需配置所以无需进行配置

 

如果OSPF邻居设备为友商产品,GR-helper配置方法需查看对应产品的配置手册确认。

例如H3C需要在OSPF进程下执行

opaque-capability enable

 

3.更改VSL链路(可选)

 

什么时候会需要更改VSL链路?

1. 由于网络改造的需要,或重新规划了端口用途,这种端口规划发生调整时,可能会涉及到VSL链路的端口发生调整。

2. 原有VSL链路或端口出现故障,需要更换端口的情况。

 

该如何更改VSL链路?

首先进入VSL端口池,然后在端口池中增加或移除端口即可。

注意:1. 以上操作在VSU模式下进行即可,不需要切换成单机模式。也不需要重启设备。

2. 所有配置只能在全局主设备上进行。

3. VSL链路两端的端口不用指定,但是端口数量要一致。例如:switch1与switch2组成2虚1的VSU系统,switch1与switch2各给出2个端口组成VSL端口池。不允许出现switch1只给1个端口,switch2上给出2个端口,或者switch1给出2个端口,switch2上给出1个端口的情况。

 

举例:

Ruijie#config

Ruijie(config)# vsl-port           -------->进入VSL-PORT配置模式  

Ruijie(config-vsl-port)# port-member interface Tengigabitethernet 1/2/3      -------->   增加端口1/2/3作为VSL口

Ruijie(config-vsl-port)# no port-member interface Tengigabitethernet 1/2/2  -------->  将1/2/2从vsl口中移除

3、聚合口配置

 

1、和办公区域连接的三层聚合口(路由口)互联,并将流量引入到防火墙进行保护。

 

 

办公区域的流量进入核心VSU时,端口设置为ACCESS VLAN 99,核心交换机上创建SVI 99与汇聚互通。

将流量引入防火墙,可将SVI99口配置为protect口use vlan 1099,防火墙内部自动生成一个桥组(vlan 99和vlan1099),交换机上会自动创建svi1099并将svi99下的配置迁移到SVI1099上,流量被发送至防火墙进行VLAN ID的转换。报文被封装VLAN1099 VID从防火墙发出至核心SVI 1099,从而实现将流量引入防火墙。本部分配置参考FW配置部分。

 

办公区域汇聚5750E上联AG1 推荐配置为路由口,避免二层报文被扩撒到核心。

 

VSU配置

 

Ruijie(config)#interface ten 1/3/2

Ruijie(config-if-TengabitEthernet 1/3/2)#port-group 3

Ruijie(config-if-TengabitEthernet 1/3/2)#exit

Ruijie(config)#interface ten 2/3/2

Ruijie(config-if-TengabitEthernet 2/3/2)#port-group 3

Ruijie(config-if-TengabitEthernet 2/3/2)#exit

Ruijie(config)#vlan 99

Ruijie(config)#interface aggregateport 3

Ruijie(config-if-AggregatePort 3)#switchport access vlan 99

Ruijie(config-if-AggregatePort 3)#exit

Ruijie(config)#interface vlan 99

Ruijie(config-if-VLAN 99)#ip add 172.16.1.10 255.255.255.252

 

将流量引到FW卡上的配置参考FW配置部分

 

 

2、和学生宿舍区域连接的三层聚合口互联,和教工宿舍区域连接的二层聚合口互联。

 

 

由于不需要受到FW卡的保护,不需要将流量通过VLAN转换的方式引入FW,所以VSU和5750直接采用路由口互联。

 

VSU配置:

 

配置和5750的三层互联:

Ruijie(config)#interface aggregateport 2

Ruijie(config-if-AggregatePort 2)#no switchport

Ruijie(config-if-AggregatePort 2)#description linktoxxxx ----->根据实际情况进行描述

Ruijie(config-if-AggregatePort 2)#exit

Ruijie(config)#interface ten 1/3/1

Ruijie(config-if-TengabitEthernet 1/3/1)#no switchport

Ruijie(config-if-TengabitEthernet 1/3/1)#description linktoyyyy ----->根据实际情况进行描述

Ruijie(config-if-TengabitEthernet 1/3/1)#port-group 2

Ruijie(config-if-TengabitEthernet 1/3/1)#exit

Ruijie(config)#interface ten 2/3/1

Ruijie(config-if-TengabitEthernet 2/3/1)#no switchport

Ruijie(config-if-TengabitEthernet 2/3/1)#description linktoyyyy ----->根据实际情况进行描述

Ruijie(config-if-TengabitEthernet 2/3/1)#port-group 2

Ruijie(config-if-TengabitEthernet 2/3/1)#exit

Ruijie(config)#interface aggregateport 2

Ruijie(config-if-AggregatePort 1)#ip add 172.16.1.6 255.255.255.252

Ruijie(config-if-AggregatePort 1)#exit

 

 

配置和2928G-E的二层互联

Ruijie(config)#interface aggregateport 4

Ruijie(config-if-AggregatePort 4)#switchport mode trunk

Ruijie(config-if-AggregatePort 4)#switchport trunk allowed vlan remove xxxx ----->根据实际情况进行裁剪

Ruijie(config-if-AggregatePort 4)#description linktoxxxx

Ruijie(config-if-AggregatePort 4)#exit

Ruijie(config)#interface gigabitEthernet 1/4/1

Ruijie(config-if-GigabitEthernet 1/4/1)#port-group 4

Ruijie(config-if-GigabitEthernet 1/4/1)#description linktoyyyy ----->根据实际情况进行描述

Ruijie(config-if-GigabitEthernet 1/4/1)#exit

Ruijie(config)#interface gigabitEthernet 2/4/1

Ruijie(config-if-GigabitEthernet 2/4/1)#port-group 4

Ruijie(config-if-GigabitEthernet 2/4/1)#description linktoyyyy ----->根据实际情况进行描述

Ruijie(config-if-GigabitEthernet 2/4/1)#exit

 

 

3、和服务器区域连接的三层聚合口互联并将流量引入到防火墙进行保护。

此配置方法和Setp1中的对办公网流量引入防火墙的方式一致,只需重新规划一对需要桥接的VLAN即可(例如VLAN98和VLAN1198)

 

3、OSPF配置

OSPF的配置为基础配置,以下为参考示例。

Ruijie(config)#interface loopback 0

Ruijie(config-if-Loopback 0)#ip address 10.10.10.1 255.255.255.255

Ruijie(config-if-Loopback 0)#exit

 

 

对于和汇聚互联的三层接口修改OSPF接口类型为point-to-point, 对端需要同样修改。

Ruijie(config)#interface aggregateport 2

Ruijie(config-if-AggregatePort 2)#ip ospf network point-to-point

Ruijie(config-if-AggregatePort 2)#exit

Ruijie(config)#interface vlan 99

Ruijie(config-if-VLAN 99)#ip ospf network point-to-point

Ruijie(config-if-VLAN 99)#exit

 

出口路由器不支持聚合所以和核心VSU的互联采用双链路配置OSPF通过负载均衡或调整链路OSPFCOST来实现主备路径。

Ruijie(config)#interface ten 1/1/2     ----->NPE互联的接口

Ruijie(config-if-TengabitEthernet 1/1/2)#no switchport

Ruijie(config-if-TengabitEthernet 1/1/2)#description linktoyyyy ----->根据实际情况进行描述

Ruijie(config-if-TengabitEthernet 1/1/2)#ip ospf network point-to-point  ----->修改OSPF接口类型为point-to-point, 对端NPE需要同样修改

Ruijie(config-if-TengabitEthernet 1/1/2)#ip add 172.16.0.2 255.255.252

Ruijie(config-if-TengabitEthernet 1/1/2)#exit

Ruijie(config)#interface ten 2/1/2     ----->NPE互联的接口

Ruijie(config-if-TengabitEthernet 2/1/2)#no switchport

Ruijie(config-if-TengabitEthernet 2/1/2)#description linktoyyyy ----->根据实际情况进行描述

Ruijie(config-if-TengabitEthernet 2/1/2)#ip ospf network point-to-point  ----->修改OSPF接口类型为point-to-point, 对端NPE需要同样修改

Ruijie(config-if-TengabitEthernet 2/1/2)#ip add 172.16.0.6 255.255.252  

Ruijie(config-if-TengabitEthernet 2/1/2)#exit

 

Ruijie(config)#router ospf 1  ----->OSPF进程根据实际规划进行配置

Ruijie(config-router)#router-id 10.10.10.1

Change router-id and update OSPF process! [yes/no]:y

Ruijie(config-router)#network 172.16.0.1 0.0.0.0 area 0            ----->和NPE互联的接口运行OSPF

Ruijie(config-router)#network 172.16.0.5 0.0.0.0 area 0 ----->和NPE互联的接口运行OSPF

Ruijie(config-router)#network 172.16.1.1 0.0.0.0 area 0 ----->和汇聚互联的接口运行OSPF

Ruijie(config-router)#network 172.16.1.5 0.0.0.3 area 0 ----->和汇聚互联的接口运行OSPF

Ruijie(config-router)#network 172.16.1.9 0.0.0.3 area 0 ----->和汇聚互联的接口运行OSPF

Ruijie(config-router)#exit

 

 

功能验证 

附件: 无  

© 2013 版权所有 鄂ICP备10021900
襄阳远达锐捷电子